Dream Spa – Health & Wellness

Get help with the Advanced Support

Dream Spa – Health & Wellness WordPress Theme Docs

We generally do not provide support for older version of the theme (version 2.4) and instead suggest that updating to the latest version of Dream Spa will be best practice

Note: Old theme (2.4 and old version) users who like to switch to new version (3.5) of our Dream Spa theme, need to use the theme in a fresh site only. The old theme datas cannot be used with the new version of the theme.

Dear Customers, We have released New Dreamspa (3.0) version (demo contents using Visual composer), please do not upload the new version of dreamspa theme or plugin files to your existing Dreamspa old version ( old page builder demo contents), since the site will crash. If you need to continue with your old version, we have provided the old version dreamspa-old.zip (2.4) separately please use those files. If you need to go with the new visual composer version, you need to install it in a fresh site.

Recent FAQ'S

In this category, we cover how you can use, categorise and customize this awesome and versatile custom post type.

Post your Comments

To get basic support and pre-purchase information via the comments section.

Help Center

This is the place to find just about anything you need to know about using your theme.